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IAR workbench is very nice development tools for ARM. You can download their kickstart version -
from their website. Kickstart version is free to download and it comes with restriction of 32KB 4 1AR Embedded Worklk
code size limit. Once you download then you can easily install it. This article describe project File Edit Yiew Project T
creating and debugging.

Before going through in details of working of IAR workbench, let me explain basics of ARM application project.
ARM application can be of two types:

1.ROM Run Application
2.RAM Run Application

ROM Run Application

Rom run application will be downloaded to flash memory and it will start executing from there only. The executable file in this case will
be pure binary file i.e. this will not contain debugging information. Extension of this file can be either bin or hex. (User can configure
project options to generate any type of file). In IAR workbench there is predefined setting of project options for generating output file
suitable for ROM run application, name of this configuration is Release configuration.
In Release configuration code is optimized in order to generate smaller and fast executable output file. And Rom version of linker script
file will be used. In this file text section of code is directed to load into ROM memory.

RAM Run Application

Ram run application will be downloaded to ram memory and it will start executing from there only. The executable file in this case will
contain debugging information. So that debugging will be easy. Purpose of type of application is only debugging and this will be not be
finally released file. These files are of ELF format.( Executable and Linkable Format)

In general these files do not have any extension. In IAR workbench there is predefined setting of project options for generating elf output
file le for RAM run application, name of this configuration is Debug configuration. And Ram version of linker script file will be used while
building the project. In this file text section of code is directed to load into RAM memory.

Downloading of such a file need JTAG debugger or bootloader program.

We hawe created a sample project for blinking of LED. This application is written for Olimex LPC2148 Board. In this board two LEDs are
connected at P0.10 and P0.11. You can easily modify code according to your LPC2148 board. This code should work for any LPC2xxx
processor.

You can download from following location
Click Here
todo give the location of code.

Creating Project
After installing IAR workbench open IAR workbench.

For that goto
Start > All Programs > IAR Systems > IAR Embedded Workbench for ARM 5.30 Kickstart > IAR Embedded Workbench
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/4 IAR Embedded Workbench IDE
File Edit %ew Project Tools ‘wWindow Help

PR REE C4Y S B P an RS,

Files B

|Ready

Go to Project > Create New Project

Create New Project |£|

Tool chain: | ARM |

Froject templates:

- Emply project
- asm
[+ C#+

i i
Externally built executable

Description:

C project uzing default tool gettings including an empty main.c file.

Ok I Cancel

Here we will choose C main project and click Ok. After that you will see option to save project file. My preferred location is
D:\Ipc2148\ledblink and project name | have given ledblink. IAR project file extension name is ewp. so my project file is ledblink.ewp.
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File Edit %ew Project Simulabor Tools  Window  Help
DEHG S

]Debug

Files £ | B int main() =
2 (Pledblink - Debug v 4 N
: S

£ Output 1 ;

ledbiink | [l [«

JReady

Tl

Ln &, Col 1

1

After saving project let us save workspace. workspace is a group of projects. For example, in case of Ipc2148 board | can create more
then one projects, so my all these project should goes under Ipc2148 workspace. So its up to user how he manage project files.

| have selected workspace name as Ipc2148work and its location will be in d:\Ipc2148. For saving project workspace goto File > Save
Workspace

and give Ipc2148work name to workspace file.

Save Workspace As

Savein: |@Ipc2148 Li &= £% -

hb () ledblirik,

My Recent
Documerts

Desktop

My Documents

o

My Computer
My Hetwark. File name: Ilpc21 Awinrk] LJ Save |
Places
Save as bype: JWorkspace Files [* eww] LJ Cancel

Extension to workspace file is eww. now click on save button and sawe it.
Now let us add source code in main file. We are writing code for Led blinking.

#include "iolpc2148.h"
#define LEDO 0x0400
#define LED1 0x0800
#include "main.h"

int main()

/¥ |nitialization ****/
PLLInit();

SCS =0x3;

/* make led line as output*/
FIOODIR |= LEDO | LED1;
FIOOSET = LEDO | LED1;
while(1)

{
/* turn off LED*/
FIOOSET = LEDO | LED1 ;
delay();
/* turn on LED*/
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FIOOCLR = LEDO | LED1 ;
delay();
}

keep main.h and iolpc2148.h files in your project directory.

There are two configuration for executable file, ram run or ram run as discussed in first paragraph of this article. Let us
discuss building of RAM Run application first.

For RAM run application we hawve to add LPC2148_RAM.icf linker script file to the project.

Click here for Part2 of the article.
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For adding linker script file right click on project options and choose options as shown in
abowe picture. or choose Project > options or use (ALT + F7).

4 1AR Embedded Workt

Eile Edit Wew Project Ti
D@L

]Debug

| Files

/% 1AR Embedded Workbench IDE

File Edit ‘iew Project Simulakor  Tools  window  Help

Ned@ 2]t =e]o o ERA S LY X Y
d main.cﬂfé:_ | i
|Debug _j /**ééf*******é#éf*******éééf********ééf*******é#éf*
-
Files o p
&  — & o ] ]
Iedbllnk—Debu Emon m.?cro declarations used for perlpherai Iso
= - arations for ++ Compiler an =8 er.
malnc 2 1 t &5 ARM TAR C/C [t 0. ol Assembl
| =0 output Make ; ;
| iD Faerosh d - yright 19595%-2005 TAR Systems. All rights reserved.
| — Biclpc214ah Rebuild Al o
| main.h Clean =vision: 21623 §
L@ 0utput
é:(-:(-:(-:(-:(-ﬁ*éﬁéé*ﬁ:éﬁﬁﬁ*ﬁﬁﬁﬁ*ﬁﬁﬁﬁﬁ*éééé*ﬁﬁﬁﬁﬁ*ﬁﬁﬁﬁﬁx
&dd »
~Bf IO MACROS H
Remove pe IO MACROS H
3 » o
edblink i Source Code Contral LIJ
= File Properties. ..
| Messages =
4 file(s) deleted.
Updating build tree... =
main.c
Linking v
ol 3
| Build | Debug Log x
Edit options for the selecked item Etrors 0, 'Warnings' i} .=
—]

After that options for node “ledblink” window will open. Here goto Linker > Config > Linker configuration file

owerride default and give path of LPC2148_RAM.icf file. For specifying path you can use IAR global variable $PROJ_DIR$ to specify
path of project directory. So according to that complete path will be following

$PROJ_DIR$\LPC2148_RAM.icf
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Options for node “ledblink™

Categon,:

CJC++ Compiler
Assembler
Output Converter
Cushom Build
Build Actions
Linker
Debugger
Simulakor
Angel
GDE Server
AR, ROM-monitor
J-Link)3-Trace
LMI FTDI
Macraigor
ROI
ST-Link
Third-Party Driver

|General Options

Factary Settings

Canfig ] Librar_l,l] Input 1 Dutput1 List ] ﬂdefine] Diagnostics] Chi t ] 5

Linker configuration file -

o5

I verride default:

|$TDDLKIT_DIH$\EDNFIG\generic. icf _J

Edi...

Lonfiguration file symbal definitions: [one per ling]

oK | Cancel

after setting of linker script file this window should be like following:

Options for node “ledblink™ EJ

Categon,:

C/C+H+ Compiler
Assembler
Output Converter
Cushom Build
Build Actions
Linker
Debugger
Simulator
Angel
GDE Server
AR, FOM-monitor
J-Link/3-Trace
LMI FTDI
Macraigor
ROI
ST-Link
Third-Party Driver

|General Opkions

Factory Settings

Canfig ] Library | Input | Output| List | #define | Diagnostics | Chi e |»

Linker canfiguration file -

v Override default

$FROJ _DIR$ALP LAk, i _J
Edit...

LConfiguration file symbol definitions: [one per ling]

Ok | Cancel

After that we have to choose project options which are following:

Processor options

Project > options > General options > Target > Processor variant > Device
click on button next to Device text box
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Options for node “ledblink™

Categon,:

ns

CJC++ Compiler
Assembler
Output Converter
Cushom Build
Build Actions
Linker
Debugger

Simulakor

Angel

GDE Server

AR, ROM-monitor

J-Link)3-Trace

LMI FTDI

Macraigor

ROI

ST-Link

Third-Party Driver

Target ] Dutput1 Library Canfiguration | Library Options | MISRA-C;200 4 ] L4

Processor variant

" Core

 Device Mone

Endian mode - |
+ Little None r
" Big

+ pE32

" BE

oK | Cancel

and choose NXP > NXP LPC2148.

Options for node “ledblink™

Categony:

G 5
C/C++ Compiler
Assembler
Qutput Converter
Cushom Build
Build Actions
Linker
Debugger
Simulator
angel
GDE Server
TAR ROM-rnonitor
J-Link]3-Trace
LMI FTDI
Macraigor
RDI
ST-Link
Third-Party Driver

Target ] Dutput1 Library Configuration | Library Options | MISRA-C: 200 4 ] L4

Processor varant

" Core

& Device |NWPLPC2143 E]

Endian mode - |
& Little r
" Big

{+ BE3Z

" BE

Ok | Cancel

Now choose j-Link as a debugger. For that go to
Project > options > Debugger > Setup > Driver
select J-Link/J-Trace from drop down menu. Left all options as it is. and click on OK.
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Options for node “ledblink™

Categony:

Debugger
Simulator
Angel
GDE Server
IAR ROM-nnonitor
J-Link{3-Trace
LMI FTDI
Macraigor
ROI
ST-Link,
Third-Parky Driver

|General Options
C]C++ Campiler
Assembler
Output Converter
Cushom Build
Build Actions
Linker

Factary Settings

Setup 1D0wnload1 Extra Dptionsi F'Iugins]

Diriver ¥ Bunto
]J -LinkAl-Trace - tnair

Setup macros

[~ Use macro file(s)

i~ Device description file
[ Owerride default

I )

Cancel ‘

now project is ready to build.

To build project pres F7.

and Start debugger. For that go to Project > Download and Debug or press (Ctrl + D).
Code will start downloading on target. Once downloading is completed then you can see debugger view of IAR workbench. Now you
can see that code is stopped at main.

4 1AR Embedded Workbench IDE

io_macros.h | main.b

finclude "iolpoZl48.h"

=23l
[ rain.c
L@ (1 Output

ledblink [l 4]

fidefine LEDO Ox0400
#define LED1 Ox0800
#include "mwain.h"

lz’li.nt, maini)
1
FEEE% Tnitiglization ##44%/
PLLInit(]:

SCS: =03

F*% make led lipne as output*/

FICODIE |= LEDO | LED1:

FICOSET = LEDO | LED1: =
while (1)

{

A* turn off LED*/
FIQOSET = LEDOD | LED1
delay();

LA Farn oan T.EDES

1or”

4nnnnisn - 21cn

4000014C 6001

4 ;
40000138 FFB8S 3
40000134 480D 1
4000013C 2103 ]
4000013E g
4 4 1
40000142 6800 1
40000144 21C0 ]
40000146 0109 1
40000148 4301 9
40000144 4804 1

c

4000014E

=

| Log

Tue Apr1312:48:17 2010: JLINK command: ProjectFils = Dpc2148Yedblinkisetingsyedblink_Debugjlink, return = 0

Tue Apr1312:4317 2010 JLINE command: device = LPC2148, return =0

£
Bl
g Debug Log | Build

Ready

ne, Col 1

Click here for Part3 of the article.
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We can do single stepping . Some of the useful commands are following:
# 1AR Embedded Workk

Eile Edit Miew Project T

Step owver F10

Step into F11

Step out Shift + F11
Go F5

Press F5 and you can see LED must be blinking on Board.

ROM run program or Flash run program

For making program to execute from run IAR has Release configuration. For that choose Release from drop down button below the
Workspace window.

# 1AR Embedded Workbench IDE

File Edit Wiew Project Simulator  Tools ‘Window Help

% %

]io_macros.h | main.b
PLLInic():

5C3 =0x3:
/% make led line as output*/
FIOODIR |= LEDO | LED1:
FICOSET = LEDO LED1:

| =0 output : !

T while (1)

| — Bio_macros.h ;

| — Biolpc2148h ) .

| L B mainh ;IOS;;; fffmz;gﬂ /’LEDl i

L@ (3 Output I !

delay():

/% turn on LED*/
FICOOCLE = LEDO | LED1 ;
delayi);

| lecbiink | fl |4

o

| Messages.
Building configuration: ledblink - Debug
Updating build tree...

Caonfiguration is up-to-date.

s
= puild |Debuglog

Ready E.Errors 0, Warnings 0

For release configuration we have to make following changes
1.Optimization

choose none optimization.
Project > options > C/C++ Compiler > Optimization > Level
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choose none

2.Linker script file for flash
Project > options > Linker > Config > Linker configuration file
choose LPC2148 flash.icf file
$PROJ_DIR$\LPC2148_flash.icf

3.Generate HEX file
Project > options > Output Conwerter > output

check on Generate additional output
choose intel extended

Options for node “ledblink™

Categone: Factory Settings

General Options
CJC++ Compiler

Assembler
Olutput

Custom Build
Build Actions
Linker
Debugger
Simulator
Angel Dutput file
GDE Server g
18R ROM-moritar I Overide default
J-Link)I-Trace I T
LMI FTDI
Macraigor
ROI
ST-Link
Third-Party Driver

¥ Generate additional output

Output format;
Jlntel extended Li

Cancel

now build the project and you can see that hex file is generated in Release folder of project directory.

This file can be downloaded into flash memory by flash magic software.
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